Upgrading to Emacs 23.2 on Ubuntu 10.04 (Lucid)

I've been frustrated at the lack of an update for the Emacs package in Ubuntu 10.04. I've been using Emacs 23.2 for OSX and going back-and-forth between 23.2 and 23.1 is confusing, particularly in org-mode. So, I searched for how to effectively build Emacs 23.2 from source in Ubuntu and had trouble finding good instructions that would cover me for things like windowing, fonts, etc. Finally, in my search this morning, I came across a the Ubuntu Emacs Lisp project on Launchpad. These folks have already done all the hard work and bundled it up into a PPA (Personal Package Archive) that will work with your existing Ubuntu update tools (apt-get).

Here's how to add the PPA to your sources list and upgrade Emacs to 23.2:

sudo add-apt-repository ppa:ubuntu-elisp/ppa
sudo apt-get update
sudo apt-get upgrade

Yep, that's it!

Tags: